Something weird in Planechasing Filip (and other events)

TremayneTremayne Posts: 1,017 Chairperson of the Boards
edited 29 July 2020, 22:00 in MtGPQ Bugs & Technical Issues
I have just finished a match of PF, where something fishy happened to my supports.

 I cast my unpredictable cyclone and everything seems fine. Greg has no support out.

next round I cycle a creature and no creature is fetched (there is an eligible creature in my deck) then I use Boles 2nd and 2 cards are drawn (which shouldn’t be possible with UC on the board.

later, I manage to get The Magic Mirror out and nothing happens at the end of my turn. TMM is killed a few rounds later without even doing its thing.

I tried repeatedly to cycle cards with UC out to no effect, extra card drawing was disabled after I recast UC.

So my conclusion is that somehow supports can be disabled across the board (or there is something dodgy with PF.

Have anyone else experienced this phenomenon?
«1

Comments

  • GormhausGormhaus Posts: 139 Tile Toppler
    My spells were not casting after the first match. Battle log says they cast but there was no effect.
  • HeartstoneHeartstone Posts: 85 Match Maker
    Same here. HUF did fetch "deploy the gatewatch", but that didn't fetch any creature.
    And Omniscience seems to be broken too: i had it in play but the cost of the cards in my hand didn't become 0
  • HeartstoneHeartstone Posts: 85 Match Maker
    Killer instinct is also dead in the planechasing event. It does not fetch anything.
    Could it be fblthp (the creature) which is broken? If fblthp the planeswalker has the creature in his deck,  it could explain all the failing creature fetches
  • HeartstoneHeartstone Posts: 85 Match Maker
    Quartzwood crasher does not create his token either... there goes my fblthp theory...
  • James13James13 Posts: 663 Critical Contributor
    edited 29 July 2020, 19:51
    I've had a number of matches since yesterday where a wide variety of card effects simply would not trigger.  Creatures, supports, etc.

    Training grounds and Fateful Showdown.  Haven't really played elsewhere.

    Among these Szasek wouldn't drain or gain buffs.  Song of creation didn't draw or discard or trigger.  Fathom mage was just a 3/3 and never triggered text.  Whirlwind of thought wouldn't trigger.  Avaricious dragon wouldn't do anything on draw.  The list is long.
  • Firstofhisname419Firstofhisname419 Posts: 54 Match Maker
    I had this happen in Rising Tensions and Training Ground while using Nissa Worldwaker.  Casting spells (March of the Multitudes, Chord of Calling, Kenrith's Transformation) did nothing (the little "poof" animation, and Battle Log indicated it was cast, but nothing).  Trostani didn't summon the two Lifelink Soldiers.  Nissa, Who Shakes the World would hit the board, but I couldn't use the +1 ability to summon tokens.  

    I switched to Koth to try to recreate the bug, but it worked fine.  I did a hard Close, and restarted the app, and was not able to recreate the bug using Nissa.  
  • HeartstoneHeartstone Posts: 85 Match Maker
    Deploy the gatewatch (without HUF) also fails in training grounds.

    All together now: do they ever test anything before releasing a new version?

  • HeartstoneHeartstone Posts: 85 Match Maker
    I tried another deck with Omniscience in planechasing,  and this time it did work. Looks like it's kind of random
  • TremayneTremayne Posts: 1,017 Chairperson of the Boards
    edited 29 July 2020, 21:22
    Ok, this exploded fast.

    I lost a match in Rising Tensions to a beautifully designed deck that relied upon Song of creation, which worked perfectly, so I can’t figure out what is going on.

    Somehow there seems to be a general problem with cards resolving their effects correctly. But it is not systematic, since the deck I used in the match described above worked fine in the first 2 matches.
  • jogamundojogamundo Posts: 83 Match Maker
    i had an event earlier today, that any effects that said "Target" wouldn't fire. The spell would cast, but the targetting wouldn't happen.
  • greenmeaniegreenmeanie Posts: 118 Tile Toppler
    edited 30 July 2020, 02:41

    Same here spells, etb effects and supports are not working.  Noticed it part way thru fblthp.  Didn't think much about then.  Just played fateful showdown and nothing is working but casting creatures.  
  • RasalghulRasalghul Posts: 146 Tile Toppler
    edited 30 July 2020, 08:19
    Just to add other examples of cards not playing it effect when cast :
    - Electrodominance does not deal damages
    - Lotus Field enters the board but does not destroy any land support then does not convert any gem.

    The game comes back fine after an closing then reopening of the app.

    The first time I encountered that effect was yesterday morning while playing TG. I live in GMT+2.
  • HeartstoneHeartstone Posts: 85 Match Maker
    Everything seems to be solved this morning :-)
  • madwrenmadwren Posts: 1,984 Chairperson of the Boards
    Still multiple reports of this still happening to some of our members as of mid-afternoon on Thursday.
  • madwrenmadwren Posts: 1,984 Chairperson of the Boards
    @Oktagon_Support This is a pretty gamebreaking bug, especially before a new coalition event starts tomorrow. Please advise.
  • JamesGamJamesGam Posts: 61 Match Maker
    Still happening and very random. 
  • ArielSiraArielSira Posts: 336 Mover and Shaker
    Supports and spells not working for me either in Fateful Showdown (Gideons Defeat, Goggles, Deploy, HUF etc)
  • ZethishZethish Posts: 33 Just Dropped In
    Just had this happen in Fateful Showdown. Could not activate vanguards and lands did not convert any gems.
    Force closed app and after restart it's back to normal, for now.
  • critmancritman Posts: 236 Tile Toppler
    I've been playing a lot over the past couple of days, mastering cards as well as playing events. things were working fine (apart from a single bug).

    Now suddenly today in a STD TG all of my cards are failing to trigger: Rakdos, Golos, Fires of Invention, Borborygmos, Greater Avatar of Iroas... none of these cards are triggering their effects. All that's happening is that my creatures are coming into play and attacking.

    Started a second game of STD TG: Same thing. My permanents were failing to trigger (Golos, Kaalia, Quartzwood Crusher, Greater Giant's Triumph). The permanent effects of Greg's Leyline of Vitality was working, so his creatures had +0/+2. Both mine and Greg's spells were failing to cast (I cast Chord of Calling and Ruinous Ultimatum, he cast Talent of the Telepath, Animist's Awakening, Circuitous Route).

    Force closed app, restarted, game 3 of STD TG, and my cards are triggering correctly now (Tested: Kaalia, Golos, Razia, Greater Avatar of Iroas, Chord of Calling).

    A Timeless Voyage starts in 22 hrs, that's going to be a right old laugh.
  • SmokincookzSmokincookz Posts: 121 Tile Toppler
    Just had Finale of Revelations cast fine in Across Ixalan, but completely fizzled in RT. Emergent Ultimatum also did nothing. Urza does not make his factory token. This is insane. It’s completely broken...
Sign In or Register to comment.