Pack-cracking bug [Devs Aware]

mrixl2520mrixl2520 Posts: 193 Tile Toppler
I noticed something weird when I opened my first Ixalan pack. First card I opened was Steadfast Armasaur. I didn't notice at first, but "NEW" did NOT flash on the card. I opened a second Steadfast Armasaur later in the pack and that one did flash "NEW." So something about the way the game is inserting cards into packs and how it reveals them is backwards...

//Edited Title -Brigby
Tagged:

Comments

  • DBJonesDBJones Posts: 803 Critical Contributor
    That didn't happen to me. I'm on Android, are you on iOS?
  • Stormbringer0Stormbringer0 Posts: 190 Tile Toppler
    Same problem here on iOS. Not that much of a deal when it’s hitting a common, but on a mythic.... I boi.
  • rafalelerafalele Posts: 876 Critical Contributor
    Same for me in Android 
  • mrixl2520mrixl2520 Posts: 193 Tile Toppler
    edited February 2018
    I am on android. I realise not the biggest bug but just thought I'd mention it :)
  • TunistTunist Posts: 15 Just Dropped In
    I had the same problem with rares.  I opened a rare and was shocked to see it converted into orbs then later on got a second copy of the same rare and it flashed new and I got to keep it.  
  • BrigbyBrigby ADMINISTRATORS Posts: 7,466 Site Admin
    If it's simply a visual bug, where the first card doesn't display NEW, then that's certainly a bug, but a minor one. Now...if the first card doesn't display NEW, but also gets converted into orbs, then that's definitely a much bigger concern. 

    Regardless, I'll be sure to pass this issue along to the QA team for review. Thanks for the heads up!
  • TunistTunist Posts: 15 Just Dropped In
    For mine it was noticable for sure as it was a rare and only the third I had opened but I am certain that the first one displayed converted to orbs and the second one showed as new.
  • Enygma6Enygma6 Posts: 260 Mover and Shaker
    This is not a new bug, I have seen it in the past when buying Premium Packs.  I have also seen it in Ixalan packs, so I recognized it as still around.  
    It feels to me that the randomly generated cards are displayed out of order for this kind of behavior to make sense.  I do not recall if it is strictly reverse order (i.e.: never seeing a duplicate after a "NEW").
  • wereotterwereotter Posts: 2,049 Chairperson of the Boards
    Brigby said:
    If it's simply a visual bug, where the first card doesn't display NEW, then that's certainly a bug, but a minor one. Now...if the first card doesn't display NEW, but also gets converted into orbs, then that's definitely a much bigger concern. 

    Regardless, I'll be sure to pass this issue along to the QA team for review. Thanks for the heads up!
    I’ve had this happen, but noticed every time that the same card appeared in a later pack and did get marked as “new” at that point. 
  • DBJonesDBJones Posts: 803 Critical Contributor
    A possibly relevant point, I'm pretty sure all the cards in a pack are chosen during the purchasing loading wheel. If you watch carefully, you can see all the runes you get from dupes get added before the opening packs animation starts.
Sign In or Register to comment.