[Android] Over a month later and the game is still showing up as "incompatible"; unable to install.

RidethepiggirRidethepiggir Posts: 2 Just Dropped In
edited 15 January 2022, 11:59 in MtGPQ Bugs & Technical Issues
Subject line says most of it. Android 11 on a OnePlus 8T + 5G and I haven't changed anything for months, but as of early December last year - right after a certain game patch that I don't have the version number of - I haven't been able to install the game. It's not that it won't install, rather that Google Play won't LET me install it. "Your device isn't compatible" is the specific error that it shows while trying from the "remote" install link - https://play.google.com/store/apps/details?id=com.d3p.olympic&hl=en_IN&gl=US - over the greyed out section for this specific device.

It's not an issue with my Google account, as I'm able to install locally or remotely to other devices plus an emulator running the same model phone. And I have a hard time believing that it's an issue with the device/OS itself, since I haven't updated anything on my end. There literally aren't any updates left for me to take prior to Android 12, which I don't want to update to yet.

Google Play support is as useless as expected and has told me that everything looks normal from their end. They refuse to help troubleshoot any further and blamed it on D3. Ticket from your support is #116377, who haven't responded for a week now either. Tried the usual steps initially to no avail (below). I just want to play the damn game while not stuck at my computer, so any help figuring out the cause of the issue would be highly appreciated.

- Have you tried all suggestions from this article (
https://support.google.com/googleplay/answer/7513003) ? Yep. No luck.
- Could you please check if you can download the game from the direct store
link (https://play.google.com/store/apps/details?id=com.d3p.olympic) ?
Still the same *"your device isn't compatible with this version."*
[redacted]
- Have you tried to clear the cache and data for the Play Store app and
your device’s download manager?


**Mod note: Removed UID number. - fight4thedream

Comments

  • FligglFliggl Posts: 20 Just Dropped In
    Don't post your UID
  • RidethepiggirRidethepiggir Posts: 2 Just Dropped In
    edited 13 January 2022, 19:14
    I appreciate the advice; will re-post without that tidbit.

    edit - or not, because I can't delete the original post either. Great choice of forum hosting software, yeesh.
  • stikxsstikxs Posts: 435 Mover and Shaker
    If you're logged into the forum you should be able to edit your post (button should be in the top right of the post, for editing the initial post it looks like the gear icon will be blue and above the post and inline with the bold subject line). Once there you can adjust the quote part.
Sign In or Register to comment.