Remove "Exclusive" from covering the card art - Make it a title just below the card title

With the influx of  "Exclusive" cards I now have a bunch of card art that I can't see unless I'm looking at the card in a match. Yes, I can click on each separate instance of the text and it goes away, but it then comes back once I click away or on a different card.

The "EXCLUSIVE!" should be something that only shows up in Vault display and only when viewing it "normally", not when looking at the card art close-up, either.

My suggestion is this:

Option 1: Reduce the font size of "EXCLUSIVE!" to the same as the card title and move it to the bottom of the card (between where the Evergreen symbols, shield, power/health would be).

Option 2: Remove the "EXCLUSIVE!" from the card, entirely, if viewing the card anywhere except the Vault. If the word still needs to exist, put it in with the text above the card. (Ex. "EXCLUSIVE! This card cannot be currently..." )


Comments

  • BlessedOneBlessedOne Posts: 162 Tile Toppler
    I second this idea. 
  • razraz Posts: 21 Just Dropped In
    You can tap the "Exclusive" to make it go away, momentarily; similar to how you can view the abilities on the full-art cards. 

    But I agree. maybe give the card a bluish glowing border/frame. Or put it below the rarity, where the "You do not own this card." message is.
  • BlessedOneBlessedOne Posts: 162 Tile Toppler
    PLEASE!
Sign In or Register to comment.