Loading Data

Artean Posts: 31
Was playing fine. Decided to support and purchased the starter pack. Got a random error. Google sent email confirming purchase. Reopen game. Stuck at loading data. Cleared data and tried reinstall. Still stuck.

11/10 would be sad cause they just wanna play.

IGN Artean


  • Malcrof
    Malcrof Posts: 5,971 Chairperson of the Boards
    Could you post device and OS type/version, this info will help in fixing issues.

  • I had pretty much the exact same issue.

    Tried to purchase the Starter Pack I got the receipt from Google Play but there was an error and it wouldn't let me redeem. I checked support and it recommended restarting my device. I did just that and when I tried to reload the game I get stuck at "Loading Data".

    I am running Android 6.0 on a Nexus 6.
  • Artean
    Artean Posts: 31
    Android 5.1.1 on a Galaxy Note 5.
  • Artean
    Artean Posts: 31
    To add to this I think it's more an issue with the files the game downloads. I tried uninstalling and then when I reinstalled I tried a different Google account on the same device, one which I don't use for gaming generally and the same thing happens. So I don't think it's my account that's the issue. Seems like something gets borked in the files and whatever it is does not get removed during uninstall/reinstall.
  • David [Hi-Fi] Moore
    David [Hi-Fi] Moore Posts: 2,872 Site Admin
    Artean wrote:
    Was playing fine. Decided to support and purchased the starter pack. Got a random error.

    Thanks for the reports. Definitely open a ticket with Customer Support if you haven't done so already: www.d3go.com/mobile-games-support

    That way, we can make sure there's a bug report entered and CS can help get you your purchase(s).

    Thank you!
  • They escalated my ticket.

    I hope to get this resolved sooner than later. I have been eagerly awaiting the release of this game.
  • Artean
    Artean Posts: 31
    I already had created a ticket. Sorry, should have mentioned that. Been working with shadow agents behind the scene and have been told a client update is needed to fix this and is in the works.
  • I have had the same issue. Bought the smallest amount option on what would 100 gold/gems ? Ever since then I can't get on back on. Just loading data and while i have a receipt for a purchase I have no idea if I ever got it. Cause I can't get back on.