Unable to complete purchase at this time

jmetznerjmetzner Posts: 5 Just Dropped In
On Mar 29, 2017 2:01:20 AM EDT, I made an in-game hero points purchase that didn't go through when the game hung on my Google Pixel XL. No big deal, these things happen, and support did credit me for my purchase. However, since then anytime I try to buy anything in the game I get the error message "Unable to complete purchase at this time." I can make purchases in other programs, so it doesn't appear to be a Google Play Store problem. Support now says "Until we have a fix released, we will place your ticket on hold in our queue and will contact you very soon with updates on the situation." Has this happened to anyone else, and if so were you able to get it fixed?

Comments

  • SeanSkiSeanSki Age Unconfirmed Posts: 1 Just Dropped In
    April 6th...got a similar issue.  I tried to purchase coins.  Got the "Unable to complete purchase at this time. Please try again later."   Haven't been able to make a purchase since.  And i didn't get the coins, or the command points.  My credit card was charged, and i have receipt in my email.  Sent all that to support and they say that they cant verify my purchase.  
  • jmetznerjmetzner Posts: 5 Just Dropped In
    This seems to have fixed itself with the Heroes for Hire store update. I tried to purchase the Danny Rand pack; that purchase went through and everything has been fine since.
  • senravensenraven Age Unconfirmed Posts: 1 Just Dropped In
    edited April 2017
    Have had the same issue since the 28th of March. Able to spend coins on covers and packs, but not able to buy coins at all or renew VIP status. Basically figuring that if this issue keeps up, once I'm out of the 6k coins that I have, I'm done playing until they fix this issue. And same response too; ticket on hold, we'll let you know blah blah blah.
Sign In or Register to comment.