Cycling not working? [Investigating]

critmancritman Posts: 236 Tile Toppler
edited 3 August 2020, 13:20 in MtGPQ Bugs & Technical Issues
I've just tried to cycle a Raugrin Triome which had mana in it (and the Cycling icon was white and not red) and received no card back again.

I did have a Fires of Invention in play, so, that might be causing a problem... but note that this is turn 1, so I've just played the Fires, it hasn't had chance to trigger yet. I include a screenshot anyway. I got a cascade, which allowed me to play a Fires and one of my Raugrin Triomes, gained an Extra Swap, and then I tried to cycle a second copy of the Triome from my hand, and got no card in return.


Comments

  • critmancritman Posts: 236 Tile Toppler
    Next game, same deck: Fires of Invention cast on turn 3, and I cycled a Raugrin Triome on turn 5, and it cycled correctly.
  • GGhorGGhor Posts: 4 Just Dropped In
    edited 29 July 2020, 18:28
    It is not working at all I had reptilian reflections on play I cycled a Sanctuary Smasher, not only it gave me no card It also did not allow me to choose the target for first strike and gave my avaricious dragon no boost... Come on guys I just lost on Trial of the planes because of this! 
  • TremayneTremayne Posts: 1,017 Chairperson of the Boards
    There are problems with many types of cards, cycling is just one example of the problems after 4.4 hit.
  • Oktagon_SupportOktagon_Support ADMINISTRATORS Posts: 978 Critical Contributor
    edited 31 July 2020, 12:49

    Hi guys,

    We're investigating this since yesterday when the first wave came.
    If you want to help with the investigation there is some information we could use.
    - The full deck you were using when it happened
    - The Planeswalker you were using
    - The event where it happened
    - Your UID
    You can send it here and tag me or through a ticket with Customer Support.

    Thank you for all the feedbacks,
    Marcela.
Sign In or Register to comment.